retrouver et lancer le tableau de bord Worpress en local après installation via XAMPP

wp-infinity
ThemeForestElegantThemes

Merci de vous inscrire pour participer au forum
Invité

Rechercher

— Forum Scope —




— Correspondances —





— Options du forum —





La longueur minimum du terme à rechercher est 3caractère - la longueur maximum est de 84 caractères

S'inscrire Mot de passe oublié ?
forum-installation
retrouver et lancer le tableau de bord Worpress en local après installation via XAMPP
BD
Membre
Membres
Messages du forum : 13
Membre depuis :
6 janvier 2015
sp_UserOfflineSmall Hors ligne
Ce message est épinglé 7
8 janvier 2015 - 16:30
sp_Permalink sp_Print

bonjour,j'ai dû me planter qq part lors des installations, voilà le message que j'obtiens quand je lance apache :

16:25:08 [main] Initializing Control Panel

16:25:08 [main] Windows Version: Windows 8 Pro 64-bit
16:25:08 [main] XAMPP Version: 5.6.3
16:25:08 [main] Control Panel Version: 3.2.1 [ Compiled: May 7th 2013 ] 16:25:08 [main] You are not running with administrator rights! This will work for
16:25:08 [main] most application stuff but whenever you do something with services
16:25:08 [main] there will be a security dialogue or things will break! So think
16:25:08 [main] about running this application with administrator rights!
16:25:08 [main] XAMPP Installation Directory: "c:\xampp\"
16:25:08 [main] Checking for prerequisites
16:25:08 [main] All prerequisites found
16:25:08 [main] Initializing Modules
16:25:08 [Apache] Problem detected!
16:25:08 [Apache] Port 80 in use by "C:\WINDOWS\syswow64\wwahost.exe" with PID 4352!
16:25:08 [Apache] Apache WILL NOT start without the configured ports free!
16:25:08 [Apache] You need to uninstall/disable/reconfigure the blocking application
16:25:08 [Apache] or reconfigure Apache and the Control Panel to listen on a different port
16:25:08 [Apache] Problem detected!
16:25:08 [Apache] Port 443 in use by "C:\WINDOWS\syswow64\wwahost.exe" with PID 4352!
16:25:08 [Apache] Apache WILL NOT start without the configured ports free!
16:25:08 [Apache] You need to uninstall/disable/reconfigure the blocking application
16:25:08 [Apache] or reconfigure Apache and the Control Panel to listen on a different port
16:25:08 [mysql] XAMPP MySQL is already running on port 3306
16:25:08 [main] The Mercury module is disabled
16:25:08 [main] The Tomcat module is disabled
16:25:08 [main] Starting Check-Timer
16:25:08 [main] Control Panel Ready
16:25:13 [Apache] Problem detected!
16:25:13 [Apache] Port 80 in use by "C:\WINDOWS\syswow64\wwahost.exe" with PID 4352!
16:25:13 [Apache] Apache WILL NOT start without the configured ports free!
16:25:13 [Apache] You need to uninstall/disable/reconfigure the blocking application
16:25:13 [Apache] or reconfigure Apache and the Control Panel to listen on a different port
16:25:13 [Apache] Problem detected!
16:25:13 [Apache] Port 443 in use by "C:\WINDOWS\syswow64\wwahost.exe" with PID 4352!
16:25:13 [Apache] Apache WILL NOT start without the configured ports free!
16:25:13 [Apache] You need to uninstall/disable/reconfigure the blocking application
16:25:13 [Apache] or reconfigure Apache and the Control Panel to listen on a different port
16:25:13 [Apache] Attempting to start Apache app...
16:25:14 [Apache] Status change detected: running

je vais tout réinstaller !!

db

BD
Membre
Membres
Messages du forum : 13
Membre depuis :
6 janvier 2015
sp_UserOfflineSmall Hors ligne
1
7 janvier 2015 - 09:01
sp_Permalink sp_Print

Bonjour,

j'ai suivi les conseils pour l'intallation de Wordpress en local via XAMPP sur mon ordi pour pouvoir développer mon site tranquillement. Par contre je ne sais pas comment lancer ou retrouver le tableau de bord pour pouvoir télécharger ou installer le thème que j'ai choisi et faire la personnalisation du site. Merci de votre aide.

Avatar
Sylvain
Modérateur
Membres

Modérateurs
Messages du forum : 195
Membre depuis :
6 janvier 2014
sp_UserOfflineSmall Hors ligne
2
7 janvier 2015 - 16:54
sp_Permalink sp_Print sp_EditHistory

Salut BD, dans ton navigateur il suffit d'aller sur http://localhost/tonnomdedomaine.com/wp-admin après avoir lancé apache et mysql avec XAMP

BD
Membre
Membres
Messages du forum : 13
Membre depuis :
6 janvier 2015
sp_UserOfflineSmall Hors ligne
3
7 janvier 2015 - 19:58
sp_Permalink sp_Print

Merci beaucoup Sylvain pour cette réponse...qui amène une autre  question ! En quoi il est utile d'ajouter le nom de mon domaine pour mon navigateur? surtout que je suis sensé travailler en local sur mon ordi et en plus  quand j'ai installée Xamp, je n'ai indiqué nulle part le nom de mon site et j'ai plutôt crée une base de données nommée différemment de mon site ? Je travaille avec Chrome comme navigateur, est il compatible avec xamp?  Encore merci d'avance pour votre aide. BD

Avatar
Sylvain
Modérateur
Membres

Modérateurs
Messages du forum : 195
Membre depuis :
6 janvier 2014
sp_UserOfflineSmall Hors ligne
4
7 janvier 2015 - 21:03
sp_Permalink sp_Print

Oui ce n'est obligatoire en effet c'est une vieille habitude je nomme toujours le dossier en local comme le nom de domaine si il existe déjà. On parle du problème ici :  COPIER UN SITE WORDPRESS EN LIGNE SUR UN SERVEUR LOCAL

Chrome ne devrait pas poser de problème, la base de donnée nommé différemment non plus. Arrives-tu à lancer ca  http://localhost/wp-admin ? Ou en ajoutant avec le nom du dossier où tu as copié wordpress.

BD
Membre
Membres
Messages du forum : 13
Membre depuis :
6 janvier 2015
sp_UserOfflineSmall Hors ligne
5
7 janvier 2015 - 22:01
sp_Permalink sp_Print

désolé ça ne marche pas ! voilà la reponse que j'obtiens : 

Objet non trouvé!

L'URL demandée n'a pas pu être trouvée sur ce serveur. Si vous avez tapé l'URL à la main, veuillez vérifier l'orthographe et réessayer.

Error 404

localhost
Apache/2.4.10 (Win32) OpenSSL/1.0.1i PHP/5.6.3
Avatar
Sylvain
Modérateur
Membres

Modérateurs
Messages du forum : 195
Membre depuis :
6 janvier 2014
sp_UserOfflineSmall Hors ligne
6
8 janvier 2015 - 14:51
sp_Permalink sp_Print

Tu as bien placé wordpress dans le dossier /XAMP/htdocs/ ?

Le contenu du dossier wordpress seulement sinon ton url serait /XAMP/htdocs/wordpress/

Ca peut donc donner soit  http://localhost/wp-admin/install.php ou http://localhost/wordpress/wp-admin/install.php

Le dossier htdocs correspond à la racine de ton hébergement local, soit http://localhost

Bien entendu il faut avoir lancé xamp, puis apache et mysql au préalable pour que ça fonctionne.

Avatar
Sylvain
Modérateur
Membres

Modérateurs
Messages du forum : 195
Membre depuis :
6 janvier 2014
sp_UserOfflineSmall Hors ligne
8
8 janvier 2015 - 16:47
sp_Permalink sp_Print

Essaie d'abord de désactiver firewall et antivirus.

BD
Membre
Membres
Messages du forum : 13
Membre depuis :
6 janvier 2015
sp_UserOfflineSmall Hors ligne
9
8 janvier 2015 - 18:18
sp_Permalink sp_Print

ça ne change rien ! Mais je pense que tu as raison, j'avais laissé les protections en place pendant les installations de XAMPP et il me semble avoir eu  des messages d'erreur engendrés par le fait que le pare feu bloquait certains fichiers. Je vais refaire en shuntant le pare feu. Je te remercie pour ton aide et n'hésiterai pas à poster qq questions si nécessaire.

db

BD
Membre
Membres
Messages du forum : 13
Membre depuis :
6 janvier 2015
sp_UserOfflineSmall Hors ligne
10
8 janvier 2015 - 19:32
sp_Permalink sp_Print

Après avoir tout nettoyé et refait une ré install complète sans pare feu, voilà le message que j'ai : 

Problem detected!
19:25:31 [Apache] Port 80 in use by "C:\WINDOWS\syswow64\wwahost.exe" with PID 6616!
19:25:31 [Apache] Apache WILL NOT start without the configured ports free!
19:25:31 [Apache] You need to uninstall/disable/reconfigure the blocking application
19:25:31 [Apache] or reconfigure Apache and the Control Panel to listen on a different port
19:25:31 [Apache] Problem detected!
19:25:31 [Apache] Port 443 in use by "C:\WINDOWS\syswow64\wwahost.exe" with PID 6616!
19:25:31 [Apache] Apache WILL NOT start without the configured ports free!
19:25:31 [Apache] You need to uninstall/disable/reconfigure the blocking application
19:25:31 [Apache] or reconfigure Apache and the Control Panel to listen on a different port

dur, dur !

bd

Avatar
Thibaud
Administrateur
Messages du forum : 345
Membre depuis :
30 septembre 2012
sp_UserOfflineSmall Hors ligne
11
8 janvier 2015 - 19:37
sp_Permalink sp_Print

Ca me rappel quelque chose ces erreurs je crois que j'étais passé par là aussi, tu as bien désactivé le pare-feu par défaut de windows ? Ou alors depuis son panneau de configuration tu peux autoriser certaines applications qui ont été bloquées, xamp devrait s'y trouver.

Il est peut être nécessaire de redémarrer l'ordi après avoir modifié les réglages du pare feu.

BD
Membre
Membres
Messages du forum : 13
Membre depuis :
6 janvier 2015
sp_UserOfflineSmall Hors ligne
12
9 janvier 2015 - 15:07
sp_Permalink sp_Print

bonjour à tous,

j'ai tout essayé ...même en neutralisant tous les pare feu et UAC mais j'ai toujours un erreur sur Apache qui l'empêche de démarrer ! 

Problem detected!
14:56:29 [Apache] Port 80 in use by "Unable to open process" with PID 2168!
14:56:29 [Apache] Apache WILL NOT start without the configured ports free!
14:56:29 [Apache] You need to uninstall/disable/reconfigure the blocking application
14:56:29 [Apache] or reconfigure Apache and the Control Panel to listen on a different port

Peut configurer manuellement d'autres ports ? et comment ? Merci de vos conseils.

db

Avatar
Thibaud
Administrateur
Messages du forum : 345
Membre depuis :
30 septembre 2012
sp_UserOfflineSmall Hors ligne
13
9 janvier 2015 - 17:03
sp_Permalink sp_Print sp_EditHistory

Il y a ça aussi : panneau de configuration / programmes / fonctionnalités de windows et décocher service internet (IIS) 

Et fermer skype si utilisé.

BD
Membre
Membres
Messages du forum : 13
Membre depuis :
6 janvier 2015
sp_UserOfflineSmall Hors ligne
14
10 janvier 2015 - 11:39
sp_Permalink sp_Print

Ouf et  Bravo ! grace à tous vos conseils, j'ai pu résoudre le problème de ports et démarré apache et mySQL, par contre je bute toujours sur l'erreur 404.  

Sur la procédure ci dessous que j'ai suivie pour l'installation de XAMPP,  il y'avait 3 modif à faire sur un fichier WP config : pour le premier, il n' y avait de souci, il fallait mettre le nom de notre base locale, mais pour le second à modifier qui est 'root' fallait il juste marquer 'root' ou il fallait le remplacer par le nom d'un "fichier racine" quelconque ?

Encore merci pour vos aides ! db

Ouvrir wp-config-sample.php et renseigner les informations de votre nouvelle base de données comme ceci ci-dessous (NB : pas besoin de mot de passe) :

/** The name of the database for WordPress */
 define('DB_NAME', 'le nom de votre base de données local');
/** MySQL database username */
 define('DB_USER', 'root');
/** MySQL database password */
 define('DB_PASSWORD', '');
/** MySQL hostname */
 define('DB_HOST', 'localhost');
  • Renommer le fichier wp-config-sample.php en wp-config.php
Avatar
Sylvain
Modérateur
Membres

Modérateurs
Messages du forum : 195
Membre depuis :
6 janvier 2014
sp_UserOfflineSmall Hors ligne
15
10 janvier 2015 - 16:52
sp_Permalink sp_Print sp_EditHistory

Il faut laisser root come user en local. Le problème venait bien du service internet (ISS) ?

  1. Si la BDD a bien été créé dans phpmyadmin en local,
  2. Si les infos de la BDD dans le fichier sont corrects et le fichier renommé wp-config.php
  3. Si le contenu du dossier wordpress est bien dans le dossier htdocs de XAMP,
  4. Si apache et mysql sont bien lancés,
  5. alors depuis ton navigateur l'URL suivante devrait t'amener vers l'installation de wordpress http://localhost/wp-admin/install.php, puis http://localhost/wp-admin/ vers ton tableau de bord.

Pour ma part j'ai créé un dossier monsite dans htdocs, pour y placer wordpress. Mes URLs sont donc http://localhost/monsite/wp-admin/install.php, puis http://localhost/monsite/wp-admin/

C'est plus propre et ça permet par ailleurs d'installer plusieurs sites en local.

N'hésites pas si tu as encore besoin d'aide.

Fuseau horaire du forum :Europe/Paris

Nb max. d'utilisateurs en ligne :574

Actuellement en ligne :
6 Invité(s)

Actuellement sur cette page :
1 Invité(s)

Auteurs les plus actifs :

BrunoT: 52

vKr_Onii: 42

bosschris: 39

athox: 26

Martine677: 25

monchihuahua: 25

Dan: 24

regisbor33: 23

monblogestunroman: 23

Nouveaux membres :

josehartsock1

Talisker25

maziecrocker

barbpaulk0349

Djiman

sherrillv03

latashaflagg556

jefferybustamant

niklasm62431705

Statistiques du forum :

Groupes :3

Forums :9

Topics :702

Posts :2782

 

Statistiques des membres :

Invités: 23

Membres : 8655

Modérateurs : 27

Admins: 1

Administrateurs :Thibaud

Modérateurs :Sylvain, bruno, david, Catherine0614, zapps, soborne, Mojiezuo, Soufian Ait Tirite, Jeff, redwhirl, sigridregnier, Jess, Malles, spleen13, Alain2choeur, kaepaul, negativenetwork, Pictures4events, 100son, Ben 44, Ailpp84, joecab, SPITI, Fatalys, Therese, P-x3l, Gayraud Marina