Sauvegarde site + bdd.

wp-infinity
ThemeForestElegantThemes

Merci de vous inscrire pour participer au forum
Invité

Rechercher

— Forum Scope —




— Correspondances —





— Options du forum —





La longueur minimum du terme à rechercher est 3caractère - la longueur maximum est de 84 caractères

S'inscrire Mot de passe oublié ?
forum-installation
Sauvegarde site + bdd.
Stefan Nunez
Membre
Membres
Messages du forum : 13
Membre depuis :
18 avril 2015
sp_UserOfflineSmall Hors ligne
1
29 mai 2015 - 20:58
sp_Permalink sp_Print

Bonjour,

J'avais créer un site web, un matin je lance wamp, et au moment d'arriver sur mon site, j'ai pleins d'erreur de connexion à la base.

Entre temps, mon ordinateur a complètement planté, j'ai du le remettre d'origine, mais avant cela, j'avais installé le plugin BackWpup en effectuant un backup de la base et du site.
Comme je n'arrive pas à restaurer, je n'ai pas le menu outil, quand j'importe le fichier .sql dans phpMyAdmin, il me dit que la base n'existe pas, bref beaucoup d'erreurs.

Donc, ma question est la suivante, connaissez-vous un moyen vraiment efficace pour sauvegarder le site (site + bdd), pour pouvoir l'exporter sur un autre ordinateur, ou bien si je remet mon ordi a 0, pouvoir le remettre, étant donné que tout est en local.

Merci d'avance pour votre aide.

Avatar
Thibaud
Administrateur
Messages du forum : 345
Membre depuis :
30 septembre 2012
sp_UserOfflineSmall Hors ligne
2
29 mai 2015 - 21:22
sp_Permalink sp_Print

Salut Stefan, as-tu essayé cet outil : Copier/Dupliquer un site WordPress sur un serveur Local ?

Stefan Nunez
Membre
Membres
Messages du forum : 13
Membre depuis :
18 avril 2015
sp_UserOfflineSmall Hors ligne
3
30 mai 2015 - 12:21
sp_Permalink sp_Print

Non je n'ai pas essayé, je vais donc recréer mo, site de 0 et faire cette technique.

Mais j'ai quelques questions:

1) Il demande d'indiquer le nouveau répertoire où sera installé WordPress, c'est à dire ? Le répertoire où sera stockée la sauvegarde ?

2) Une fois que j'ai fait la sauvegarde, duplication... Comment faire pour restaurer mon site ?

3) Est-ce que cela sauvegarde aussi la bdd ?

Stefan Nunez
Membre
Membres
Messages du forum : 13
Membre depuis :
18 avril 2015
sp_UserOfflineSmall Hors ligne
4
30 mai 2015 - 12:35
sp_Permalink sp_Print

Ah oui j'ai oublié.

Dois-je installer xampp ? Ou bien wamp fera aussi l'affaire?

Avatar
Thibaud
Administrateur
Messages du forum : 345
Membre depuis :
30 septembre 2012
sp_UserOfflineSmall Hors ligne
5
30 mai 2015 - 15:14
sp_Permalink sp_Print

1 - Le répertoire c'est le dossier où sera installé wordpress, puis il faut indiquer les identifiants de la base de données à part.

2 - Il faudra lancer un script placé dans le dossier WordPress pour lancer l'installation, il sera dispo après avoir fait la sauvegarde.

3 - Oui ça sauvegarde tout, à moins d'avoir appliqué des filtres.

Je préfère XAMPP, mais WAMP devrait faire l'affaire, surtout si tu as déjà l'habitude de WAMP. J'avais expliqué pourquoi je préfère XAMPP dans cet article : Installer WordPress en Local

Stefan Nunez
Membre
Membres
Messages du forum : 13
Membre depuis :
18 avril 2015
sp_UserOfflineSmall Hors ligne
6
31 mai 2015 - 00:06
sp_Permalink sp_Print

Je préfère rester sur wamp, car ça fait plusieurs années que je l'utilise et y suis habituer, mais bon pourquoi un jour essayer xampp.

Je viens donc de créer ma sauvegarde à l'aide du plugin duplicator.

Mais comment faire pour emporter mon site sur un autre ordinateur ? Je dois installer wamp, puis ensuite copier le dossier de mon site dans le dossier www de wamp, puis il est dit qu'il faut créer une bdd au préalable, mais si je la créer avant, elle sera vide, elle ne contiendras pas le contenu de mon site.

Avatar
Thibaud
Administrateur
Messages du forum : 345
Membre depuis :
30 septembre 2012
sp_UserOfflineSmall Hors ligne
7
1 juin 2015 - 14:11
sp_Permalink sp_Print

Oui il faut la créer vide puis indiquer à duplicator les infos de connexion pour qu'il puisse y installer les tables nécessaires.

Stefan Nunez
Membre
Membres
Messages du forum : 13
Membre depuis :
18 avril 2015
sp_UserOfflineSmall Hors ligne
8
1 juin 2015 - 14:40
sp_Permalink sp_Print

Ok, je vais essayer tout cela, et je reviens vers toi pour indiquer si tout à bien fonctionné.

Stefan Nunez
Membre
Membres
Messages du forum : 13
Membre depuis :
18 avril 2015
sp_UserOfflineSmall Hors ligne
9
1 juin 2015 - 15:57
sp_Permalink sp_Print

J'ai installé wamp server sur un autre ordinateur, j'ai ensuite crée une bdd, ensuite j'ai créer un dossier avec le nom de mon site dans le dossier wamp/www.

J'ai copié le zip (paquet) et installer.php dans wamp/www. J'ai donc lancé installer.php, j'ai rentré les identifiants de la base, puis les chemins d'installation.

Et quand je lance mon site, il m'affiche ceci:

http://img11.hostingpics.net/pics/746290Sanstitre.pngImage Enlarger

Avatar
Thibaud
Administrateur
Messages du forum : 345
Membre depuis :
30 septembre 2012
sp_UserOfflineSmall Hors ligne
10
1 juin 2015 - 16:17
sp_Permalink sp_Print

Umm  c'est bizarre, je n'ai jamais eu ça. Tu as bien effectué toutes les étapes de contrôle suggérées à la fin par le script installer.php ?

On dirait qu'il manque le fichier index.php non ?

Stefan Nunez
Membre
Membres
Messages du forum : 13
Membre depuis :
18 avril 2015
sp_UserOfflineSmall Hors ligne
11
1 juin 2015 - 18:12
sp_Permalink sp_Print

Juste en dessous de ce tableau, il m'affiche ceci:

 

Installation : la fameuse installation en 5 minutes

  1. Décompressez l'archive dans un dossier vide de votre ordinateur, puis mettez tous ces fichiers en ligne ;
  2. Ouvrez le fichier 

    wp-config-sample.php

     avec votre éditeur de texte préféré, comme WordPad ou similaire, et complétez les informations liées à votre base de données ;

  3. Sauvegardez le fichier sous le nom 

    wp-config.php

     ;

  4. Envoyez le tout sur votre hébergement via un logiciel client FTP ;
  5. Ouvrez le fichier /wp-admin/install.php dans votre navigateur. Celui-ci vous guidera dans la création du fichier 

    wp-config.php

    , qui contient les détails de connexion à votre base de données ;

    1. Si cela ne marchait pas, ne vous inquiétez pas : certains hébergeurs n'autorisent pas la création de fichier. Ouvrez le fichier 

      wp-config.php

       avec un éditeur de texte, et saisissez-y directement les détails de connexion à votre base de données ;

    2. Enregistrez le fichier sous le nom 

      wp-config.php

       et mettez-le en ligne ;

    3. Ouvrez le fichier wp-admin/install.php dans votre navigateur ;
  6. Une fois le fichier de configuration correctement rempli, l'installateur met en place les tables nécessaires à votre blog. Si vous obtenez une erreur, vérifiez le contenu du fichier 

    wp-config.php

    , et réessayez. Si cela échoue encore une fois, rendez-vous sur les forums d'entraide et soyez le plus précis possible dans vos explications. Si tout se passe bien, passez à l'étape suivante ;

  7. Si vous n'avez pas précisé de mot de passe, notez bien celui qui vous est donné. Si vous n'avez pas précisé d'identifiant utilisateur, ce sera 

    admin

     ;

  8. Une fois l'installation terminée, le script d'installation vous renverra vers la page de connexion. Connectez-vous avec l'identifiant et le mot de passe précisés (ou générés) durant l'installation. Si le mot de passe a été généré pour vous, cliquez sur "Profil" pour le modifier.

 

Je vais résumer à nouveau la procédure que j'ai suivie:

1) Je créer le paquet zip + installer.php

2) Sur le 2ème ordinateur, j'installe wamp server

3) Je vais dans wamp/www, je créer un dossier vide avec le nom du site "ICE"

4) Je colle dans wamp/www, le fichier zip (paquet) + installer.php

5) Je crée une base vide du même nom que l'originale.

6) Je lance installer.php, je fait test connection, tout est ok

7) Je fait run deployment, dans NEW SETTINGS, j'indique l'url suivante: http://localhost/ICE

Puis dans path: C:/wamp/www/ICE

Je met ICE, car c'est le nom du dossier de mon site.

8) Je clique sur Run update, et j'obtiens ces messages.

Avatar
Thibaud
Administrateur
Messages du forum : 345
Membre depuis :
30 septembre 2012
sp_UserOfflineSmall Hors ligne
12
1 juin 2015 - 18:21
sp_Permalink sp_Print

Essayes peut-être de créer un nouveau paquet zip, la méthode me semble tout à fait correct. 

Stefan Nunez
Membre
Membres
Messages du forum : 13
Membre depuis :
18 avril 2015
sp_UserOfflineSmall Hors ligne
13
1 juin 2015 - 18:35
sp_Permalink sp_Print

Ce qui est bizarre, c'est que j'indique bien que le nouveau chemin est C:/wamp/www/ICE, et il me met les fichiers dans wamp/www, et non dans wamp/www/ICE.

Quand je regarde le contenu des tables, dans phpMyAdmin, ça m'a l'air correct.

Je viens d'essayer avec un nouveau paquet, et j'ai toujours pareil.

Stefan Nunez
Membre
Membres
Messages du forum : 13
Membre depuis :
18 avril 2015
sp_UserOfflineSmall Hors ligne
14
1 juin 2015 - 20:52
sp_Permalink sp_Print

Lorsque je créer un dossier dans wamp/www sur le second ordinateur, je mettais le même nom qu'avant, j'ai essayé avec un nom de dossier différent, et là ça fonctionne, donc au lieu de le nommer ICE, j'ai mis ICEcopy.

J'ai ma page principale qui s'affiche, mais quand je me déplace sur une autre page via les menus, j'ai une erreur 404:

 

Not Found

The requested URL /ICEcopy/pc77-presentation was not found on this server.

Stefan Nunez
Membre
Membres
Messages du forum : 13
Membre depuis :
18 avril 2015
sp_UserOfflineSmall Hors ligne
15
1 juin 2015 - 21:06
sp_Permalink sp_Print

Désolé d'ajouter un 3ème post, mais je viens de trouver la solution, tout marche correctement, j'accède à toutes mes pages.

Cette erreur vient des permaliens, et il faut en plus activer le module apache "rewrite_module".

Fuseau horaire du forum :Europe/Paris

Nb max. d'utilisateurs en ligne :574

Actuellement en ligne :
5 Invité(s)

Actuellement sur cette page :
1 Invité(s)

Auteurs les plus actifs :

BrunoT: 52

vKr_Onii: 42

bosschris: 39

athox: 26

monchihuahua: 25

Martine677: 25

Dan: 24

monblogestunroman: 23

regisbor33: 23

Nouveaux membres :

Talisker25

maziecrocker

barbpaulk0349

Djiman

sherrillv03

latashaflagg556

jefferybustamant

niklasm62431705

kerry9554@aol.com

Statistiques du forum :

Groupes :3

Forums :9

Topics :702

Posts :2782

 

Statistiques des membres :

Invités: 23

Membres : 8654

Modérateurs : 27

Admins: 1

Administrateurs :Thibaud

Modérateurs :Sylvain, bruno, david, Catherine0614, zapps, soborne, Mojiezuo, Soufian Ait Tirite, Jeff, redwhirl, sigridregnier, Jess, Malles, spleen13, Alain2choeur, kaepaul, negativenetwork, Pictures4events, 100son, Ben 44, Ailpp84, joecab, SPITI, Fatalys, Therese, P-x3l, Gayraud Marina