Thème enfant - responsive css

ThemeForestElegantThemes

Merci de vous inscrire pour participer au forum
Invité

Rechercher

— Forum Scope —




— Correspondances —





— Options du forum —





La longueur minimum du terme à rechercher est 3caractère - la longueur maximum est de 84 caractères

S'inscrire Mot de passe oublié ?
forum-theme
Thème enfant - responsive css
silv-eto
Membre
Membres
Messages du forum : 1
Membre depuis :
31 juillet 2015
sp_UserOfflineSmall Hors ligne
1
31 juillet 2015 - 18:07
sp_Permalink sp_Print

Bonjour,

- Version de WordPress : 4.2.3
- Thème utilisé : AccessPress Lite

J'ai un problème de style css en version mobile et tablette. Voici comment j'ai procédé. (Je suis débutante en Wordpress)

J'ai crée un thème enfant - Accesspress-lite-child dans le répertoire C:\wamp\www\wordpress\wp-content\themes
Dans mon dossier Accesspress-lite-child, j'ai créé un fichier style.css avec le code suivant :
/*
Theme Name: Accesspress Lite-Child
Description: Thème enfant pour Accesspress Lite
Author: Tomova
Template: accesspress-lite
*/
@import url("../accesspress-lite/style.css");

Ensuite j'ai mis les modifications de style que je voulais. Celles-ci sont bien appliquées sur mon site (version desktop).

En effet le thème Parent AccessPress-lite contient plusieurs fichiers css dont responsive.css dans le répertoire wordpress\wp-content\themes\accesspress-lite\css
Quand je redimensionne en taille mobile et tablette, le background du menu est bleu (couleur d'origine) et non pas marron comme je le souhaite. En effet cela se définit dans le fichier responsive.css.

Du coup j'ai créé un dossier css dans mon dossier de thème enfant et j'ai crée un fichier responsive.css (wp-content\themes\accesspress-lite-child\css ). J'ai mis le code suivant :
/*This styles is for the responsive layout of the theme*/
/*
Theme Name: Accesspress Lite-Child
Description: Thème enfant pour Accesspress Lite
Author: Tomova
Template: accesspress-lite
*/
@import url("../accesspress-lite/css/responsive.css/");
Et ensuite le code css avec les bonnes couleurs. Mais ça ne marche pas, les modifications ne sont pas prises en compte.

J'ai créé également un fichier function.php avec le code suivant :
<?php
add_action( 'wp_enqueue_scripts', 'theme_enqueue_styles' );
function theme_enqueue_styles() {
    wp_enqueue_style( 'parent-style', get_template_directory_uri() . '/style.css' );
    wp_enqueue_style( 'parent-style', get_template_directory_uri() . '/css/responsive.css' );
}
?>

Merci de m'indiquer mes erreurs :)

Fuseau horaire du forum :Europe/Paris

Nb max. d'utilisateurs en ligne :574

Actuellement en ligne :
6 Invité(s)

Actuellement sur cette page :
1 Invité(s)

Auteurs les plus actifs :

BrunoT: 52

vKr_Onii: 42

bosschris: 39

athox: 26

monchihuahua: 25

Martine677: 25

Dan: 24

monblogestunroman: 23

regisbor33: 23

Nouveaux membres :

Kevin Koussougbe

ivyclubbe56

jocuricubarbie259

Soufiane Jebari

sflbirgit6463226

marcelinolillard

franziskaj8621

tylerhillary

mac0942

Statistiques du forum :

Groupes :3

Forums :9

Topics :718

Posts :2806

 

Statistiques des membres :

Invités: 23

Membres : 8949

Modérateurs : 27

Admins: 1

Administrateurs :Thibaud

Modérateurs :Sylvain, bruno, david, Catherine0614, zapps, soborne, Mojiezuo, Soufian Ait Tirite, Jeff, redwhirl, sigridregnier, Jess, Malles, spleen13, Alain2choeur, kaepaul, negativenetwork, Pictures4events, 100son, Ben 44, Ailpp84, joecab, SPITI, Fatalys, Therese, P-x3l, Gayraud Marina