Merci de vous inscrire pour participer au forum
Invité

Rechercher

— Forum Scope —




— Correspondances —





— Options du forum —





La longueur minimum du terme à rechercher est 3caractère - la longueur maximum est de 84 caractères

S'inscrire Mot de passe oublié ?
forum-plugin
Problèmes Plugins : SEO yoast & polylang
rocosta1959@gmail.com
Membre
Membres
Messages du forum : 11
Membre depuis :
15 mars 2017
sp_UserOfflineSmall Hors ligne
1
7 janvier 2016 - 12:08
sp_Permalink sp_Print

Bonjour,

J'ai installé 2 plugins: SEO Yoast et polylang.

En ce qui concerne SEO Yoast: J'ai pré rempli les élements pour le fil d'ariane. Mais le fil d'ariane n'apparaît nulle part lorsque je navigue. Est-ce normale? De même que j'aimerais intégrer un plan du site avec ce même plugin qui le fait normalement automatiquement. Comment faire?

Et enfin, en ce qui concerne polylang : j'aimerais avoir un site multilingue : Français et anglais. mais lorsque j'active ce plugin et que j'ajoute une langue. mes permaliens se perdent. Comment dois-je régler ce plugin pour faire en sorte que je ne perdent pas mes liens.

Merci bien

Avatar
Thibaud
Administrateur
Messages du forum : 362
Membre depuis :
25 octobre 2018
sp_UserOfflineSmall Hors ligne
2
12 janvier 2016 - 13:53
sp_Permalink sp_Print

Bonjour,

avec YOAST il faut ajouter un bout de code manuellement dans ton fichier header.php pour afficher le fil d'ariane.

Ton plan de site, si l'option est activée dans YOAST, se situe à l'URL http://exemple.com/sitemap_index.xml

Avatar
Thibaud
Administrateur
Messages du forum : 362
Membre depuis :
25 octobre 2018
sp_UserOfflineSmall Hors ligne
3
12 janvier 2016 - 13:55
sp_Permalink sp_Print

Pour polylang je passe la main car je ne connais pas assez bien, j'utilise WPML. Pense à sauvegarder de nouveau tes permaliens tout de même, cela régénère le fichier .htaccess.

rocosta1959@gmail.com
Membre
Membres
Messages du forum : 11
Membre depuis :
15 mars 2017
sp_UserOfflineSmall Hors ligne
4
22 janvier 2016 - 15:36
sp_Permalink sp_Print

Justement pour YOAST, j'ai ajouté le code suivant pour activer le fil d'ariane:  

<?php if ( function_exists('yoast_breadcrumb') )
{yoast_breadcrumb('<p id="breadcrumbs">','</p>');} ?>

Mais tout a planté. Je ne peux plus accéder à mon site.
Une erreur survient : Erreur serveur 500.

Que faire?

Aidez moi
Merci

Avatar
Thibaud
Administrateur
Messages du forum : 362
Membre depuis :
25 octobre 2018
sp_UserOfflineSmall Hors ligne
5
22 janvier 2016 - 15:41
sp_Permalink sp_Print

Ouvre de nouveau le fichier via FTP et supprime toutes modifs.

Tu l'as surement mis au mauvais endroit, tout simplement.

rocosta1959@gmail.com
Membre
Membres
Messages du forum : 11
Membre depuis :
15 mars 2017
sp_UserOfflineSmall Hors ligne
6
22 janvier 2016 - 15:57
sp_Permalink sp_Print

D'accord. et je fait sa, je perdrais tout? ou uniquement les dernières modifications?

Car j'ai tout sauvegardé normalement...

rocosta1959@gmail.com
Membre
Membres
Messages du forum : 11
Membre depuis :
15 mars 2017
sp_UserOfflineSmall Hors ligne
7
22 janvier 2016 - 15:59
sp_Permalink sp_Print

Pourriez vous me dire à quel endroit exactement, devrais-je mettre ce code?

Avatar
Thibaud
Administrateur
Messages du forum : 362
Membre depuis :
25 octobre 2018
sp_UserOfflineSmall Hors ligne
8
22 janvier 2016 - 16:01
sp_Permalink sp_Print sp_EditHistory

Si tu n'est pas sûr de ce qu'il faut supprimer, remplace le fichier modifié par la version originale.

Il faut coller ce code dans le fichier header.php de ton thème, sous le menu par exemple.

Avatar
Thibaud
Administrateur
Messages du forum : 362
Membre depuis :
25 octobre 2018
sp_UserOfflineSmall Hors ligne
rocosta1959@gmail.com
Membre
Membres
Messages du forum : 11
Membre depuis :
15 mars 2017
sp_UserOfflineSmall Hors ligne
10
31 janvier 2016 - 16:47
sp_Permalink sp_Print

Merci pour ces infos!

 

heureusement, j'avais programmé une sauvegarde automatique, donc j'ai tout rechargé (meme si j'ai perdu 1 à 2 jour de travail...)

 

Je retesterai l'insertion du code plus tard pour le fil d'ariane

 

A bientôt Thibaud

Fuseau horaire du forum :Europe/Paris

Nb max. d'utilisateurs en ligne :574

Actuellement en ligne :
3 Invité(s)

Actuellement sur cette page :
1 Invité(s)

Auteurs les plus actifs :

Nouveaux membres :

rochellsanford0

judibolard

Alain Guimpier

cheri78y293006

ofeliasummers41

jonahboag93018

isadoravieira51

jedleckie7287

Léo Malfuson

leomalfuson

Statistiques du forum :

Groupes :1

Forums :9

Topics :798

Posts :2927

 

Statistiques des membres :

Invités: 23

Membres : 10135

Modérateurs : 1

Admins: 1

Administrateurs :Thibaud

Modérateurs :Thibaud1