Mise à jour impossible | Forum WordPress


Rechercher

— Forum Scope —




— Correspondances —





— Options du forum —





La longueur minimum du terme à rechercher est 3caractère - la longueur maximum est de 84 caractères

Mot de passe oublié ?
forum-installation
Mise à jour impossible
Ajouter une réponse
Pierre-Antoine Légoutière
Membre
Membres
Messages du forum : 5
Membre depuis :
4 août 2016
Hors ligne
1
4 août 2016 - 10:56

Débutant. Mon WP est installé en local. A chaque tentative de mise à jour vers WordPress 4.5.3 ou d'installation de thème, je reçois le message d'erreur suivant :
Le téléchargement a échoué.:
SSL certificate problem, verify that the CA cert is OK. Details: error:14090086:SSL routines:SSL3_GET_SERVER_CERTIFICATE:certificate verify failed

Ma configuration WP actuelle : - Version de WordPress : 3.4.2
- Version de PHP/MySQL : 5.3.2 / 5.1.46
- Thème utilisé : Twenty Eleven
- Thème URI : http://wordpress.org/extend/themes/twentyeleven
- Extensions en place : Forum_wordpress_fr (4.1), WordPress Importer (0.6), WP Native Dashboard (1.3.8)
- Adresse du site : http://127.0.0.1:4001/wordpress
- Nom de l'hébergeur : Apache/2.2.15 (Win32) PHP/5.3.2

Avatar
redwhirl
Modérateur
Membres

Modérateurs
Messages du forum : 19
Membre depuis :
7 août 2014
Hors ligne
2
4 août 2016 - 17:32

Bonjour,

Première chose à faire est de faire évoluer vos versions de Php (actuellemnt 5.6.24) et de Mysql (actuellement 5.7.14) ce qui pourrait expliquer les problèmes de mise à jour.

Si vous ne savez comment faire, vous pouvez installer laragon.org pour faire tourner votre installation en local avec un serveur récent.

Sinon,

La solution la plus simple, puis vous êtes en local, téléchargez la dernière version de WordPress. Extraire dans un répertoire temporaire. Désactiver tous vos plugin. Copier le contenu du dossier WordPress que vous venez d'extraire dans le répertoire de votre installation actuelle, et écrasez les fichiers lorsque la question sera posée.

Relancez WordPress, une mise à jour de la base de données se fera. Faites la mise à jour des plugin s'il y en a. Il ne restera plus qu'à réactiver les plugin l'un après l'autre pour éviter les incompatibilités.

Faites une copie de votre installation au préalable, pour éviter tout problème.

Pierre-Antoine Légoutière
Membre
Membres
Messages du forum : 5
Membre depuis :
4 août 2016
Hors ligne
3
4 août 2016 - 18:44

Bien. J'ai donc :

1) Désactivé les trois extensions actives

2) Remplacé la version de WordPress selon votre procédure.

Aucun changement. Sinon que le tableau de bord de WP apparaît désormais en anglais

Question : où doit-être installé WordPress ? N'importe où sur le PC ? Dans le dossier InstantWP ? Dans un dossier spécifique du système ?

Merci beaucoup de votre aide

Avatar
redwhirl
Modérateur
Membres

Modérateurs
Messages du forum : 19
Membre depuis :
7 août 2014
Hors ligne
4
4 août 2016 - 20:46

Je ne connais pas InstantWP, mais généralement il y a un dossier www ou htdocs dans le répertoire de ce genre d'outils

Voyez dans le dossier d'Instant WP vous devriez y retrouver votre site.

Hubert

Pierre-Antoine Légoutière
Membre
Membres
Messages du forum : 5
Membre depuis :
4 août 2016
Hors ligne
5
4 août 2016 - 22:22

OK. Tout se présente mieux, après avoir installé la bonne version de WP dans le dossier htdocs de InstantWordPRess .

En revanche, il me demande maintenant mes identifiants et password MysQL. Où puis-le les fixer où les modifier ? Pas la moindre idée...

Pierre-Antoine Légoutière
Membre
Membres
Messages du forum : 5
Membre depuis :
4 août 2016
Hors ligne
6
4 août 2016 - 22:37

En fait, il me demande toutes les informations dans cette boîte de dialogue, et là j'avoue que je reste sec...

Avatar
redwhirl
Modérateur
Membres

Modérateurs
Messages du forum : 19
Membre depuis :
7 août 2014
Hors ligne
7
5 août 2016 - 09:34

A priori le problème n'est pas résolu. En installant dans le bon dossier il n'a pas besoin de ces identifiants. Vérifiez si il n'a pas tout simplement copier les fichiers dans un sous dossier nommé wordpress. si c'est le cas les fichiers de ce sous dossirs doivent être copiés dans le dossier parent.

Pierre-Antoine Légoutière
Membre
Membres
Messages du forum : 5
Membre depuis :
4 août 2016
Hors ligne
8
5 août 2016 - 11:43

Bien. J'ai totalement refait l'installation en repartant de zéro. Un élément perturbait le bazar : le plugin "native-dashbord", que j'ai donc éliminé. Disposant dès lors de la version 4.5.3 de Wordpress en anglais, j'ai rechargé et réactivé le plugin. Donc désormais tout semble aller bien. Je passe à l'installation de mon premier thème. Je reviens vers vous si Pb. Merci infiniment, vous êtes mon sauveur !

Avatar
redwhirl
Modérateur
Membres

Modérateurs
Messages du forum : 19
Membre depuis :
7 août 2014
Hors ligne
9
5 août 2016 - 12:56

Voilà une bonne chose. Pour passer en Français, allez à Settings puis General dans le menu, puis tout en bas de l'écran sélectionné Français.

Bonne continuation

Fuseau horaire du forum :Europe/Paris

Nb max. d'utilisateurs en ligne :574

Actuellement en ligne :
14 Invité(s)

Actuellement sur cette page :
1 Invité(s)

Auteurs les plus actifs :

Bruno: 52

Robin: 44

vKr_Onii: 41

bosschris: 39

Dan: 27

Nouveaux membres :

Nathalie_1

Patrice_1

Jp

Richard_1

Jean Luc_1

Statistiques du forum :

Groupes :1

Forums :7

Topics :592

Posts :2412

 

Statistiques des membres :

Invités: 35

Membres : 9957

Modérateurs : 26

Admins: 2

Administrateurs :wpengine, Thibaud

Modérateurs :Gebhard, david, Catherine1, zapps, soborne, mojiezuo, Soufian, Jeff, redwhirl, sigridregnier, Jessica, Benjamin2, spleen13, Alain Web-creator, kaepaul, negativenetwork, Gaetan1, Samson, Benoit1, Ailpp84, Joel2, Catherine2, Fatalys, Therese, Guillaume3, Gayraud

En ligne

19 visiteurs, 15 membres

Messages récents